- 5.1 How Oracle VM VirtualBox Works
- 5.2 Oracle VM VirtualBox Guest Platform
- 5.3 Oracle Solaris as an Oracle VM VirtualBox Host
- 5.4 Oracle Solaris as an Oracle VM VirtualBox Guest
- 5.5 Creating and Managing Oracle VM VirtualBox Guests
- 5.6 Summary
5.3 Oracle Solaris as an Oracle VM VirtualBox Host
VirtualBox supports Solaris 10 5/09 and later as a host platform with a few restrictions:
- There is no support for USB. VirtualBox uses a newer USB device management system that was introduced into OpenSolaris build 124 and is not available in Solaris 10.
- ACPI information, such as battery status and power source, is not reported to guest operating systems.
- Wireless network adapters cannot be used for bridged networks.
VirtualBox can run in either the global zone or a Solaris Container. Running in a Container provides several interesting benefits. It may be easier to place resource controls on an entire Container than an arbitrary workload, especially if different people are tasked with these functions. The global zone administrator can place resource policies on the Container that the VirtualBox user may not be aware of or have sufficient privilege to set. Migrating a Container by detaching it from one host and attaching it to another host can greatly simply the task of relocating a guest. Most of the configuration settings needed for proper operation of the guest are contained in the Container configuration file, so any changes that need to be made can be done in one place. Finally, the ability to clone a Container that contains a guest and its associated data makes it easier to rapidly deploy several copies of the same machine on the host.
To enable VirtualBox operation in a Container, just add the device /dev/vboxdrv to the Container. For OpenSolaris hosts for which you want to enable USB support, add the device /dev/vboxusbmon in addition to /dev/vboxdrv. The following example shows the creation of a Container called WinXP that could be used to run VirtualBox guests. A more detailed example is provided in Chapter 8, "Applying Virtualization."
# zonecfg -z WinXP WinXP: No such zone configured Use 'create' to begin configuring a new zone. zonecfg:WinXP> create zonecfg:WinXP> set zonepath=/zones/WinXP zonecfg:WinXP> add device zonecfg:WinXP:device> set match=/dev/vboxdrv zonecfg:WinXP:device> end zonecfg:WinXP> add net zonecfg:WinXP:net> set physical=e1000g0 zonecfg:WinXP:net> set address=192.168.1.41/24 zonecfg:WinXP:net> end zonecfg:WinXP> exit # zoneadm -z WinXP install Preparing to install zone <WinXP>. Creating list of files to copy from the global zone. Copying <35929> files to the zone. # zoneadm -z WinXP boot # zlogin -C WinXP
Finish the installation as you would any other Container by answering the Solaris system identification questions. Once this step is complete, you can use the VirtualBox graphic or command-line tools just as you would in the global zone. Some of the host networking modes may require the use of exclusive IP for configuration of the guest's virtual network interface.
Another Oracle Solaris feature that can be used by VirtualBox is ZFS. Although VirtualBox has a host-independent disk cloning feature, it works by copying entire disk images—an approach that doubles the amount of storage required for the duplicated clone and places a heavy load on the host system during the copying operation. By comparison, ZFS has a fast cloning capability that takes significantly less time to complete; the cloned disk image needs to store only those blocks that are different from the blocks in the original image. This strategy is very efficient for deploying many copies of the same type of guest.
When running VirtualBox on a Solaris host that is also using ZFS, limiting the size of the adaptive replacement cache (ARC) is recommended. By default, ZFS can use most of the physical memory on the system: up to three-fourths on systems with 4 GB or less and up to maxphys-1 GB on larger systems. A guest may demand memory faster than ZFS is able to free it, which would produce one of the memory shortfall situations we are trying to prevent. The solution is to limit the amount of memory that ZFS is able to use for the ARC. This cap can be set with the zfs_arc_max Solaris tunable parameter, which you can set in /etc/system.
The following setting will limit the ARC to 1 GB, which is a reasonable value for a 4 GB desktop hosting several virtual machines:
set zfs:zfs_arc_max = 0x40000000
As a general rule, do not set zfs_arc_max equal to more than three-fourths of the physical memory that is left after allocating memory for all of your guests.
See Chapter 8, "Applying Virtualization," for an example of using both ZFS and Containers for rapid provisioning of guests on an Oracle Solaris host.
5.3.1 Installing Oracle VM VirtualBox
The VirtualBox software can be downloaded from http://virtualbox.org/downloads. The Oracle Solaris version is provided in a single SVR4 data stream package that includes both the 32-bit and 64-bit versions of the software as well as a README text file describing the installation process and a package answer file named autoresponse for non-interactive installations. Because the package installation scripts load kernel modules, the installation must be done in the global zone and carried out either by root or by a user or role that has the Software Installation execution profile.
If an older version of VirtualBox is installed on the host, it must be removed before installing the new version. For versions prior to 3.1, two packages must be uninstalled: SUNWbox and SUNWvboxkern. Starting with version 3.1, there is just a single package: SUNWvbox. It is not necessary to reboot the Solaris host after the old version of VirtualBox is removed or the new version is installed.
In the next example, a new version of VirtualBox is installed on a system that is already running an older release. Note the use of the included autoresponse file for unattended package operations.
# ls VirtualBox-3.1.4-57640-SunOS.tar.gz # /usr/sfw/bin/gtar xpzf VirtualBox-3.1.4-57640-SunOS.tar.gz # ls ReadMe.txt VirtualBox-3.1.4-57640-SunOS.tar.gz VirtualBox-3.1.4-SunOS-r57640.pkg autoresponse # pkgrm -n -a autoresponse SUNWvbox Removing VirtualBox drivers and services... - Unloaded: Web service - Unloaded: Zone access service - Unloading: USB ...FAILED! - Removed: USB module - Unloaded: USBMonitor module - Removed: USBMonitor module - Unloaded: NetFilter module - Removed: NetFilter module - Unloaded: NetAdapter module - Removed: NetAdapter module - Unloaded: Host module - Removed: Host module Done. # pkgadd -n -a autoresponse -d VirtualBox-3.1.4-SunOS-r57640.pkg all Checking for older bits... Installing new ones... Loading VirtualBox kernel modules... - Loaded: Host module - Loaded: NetAdapter module - Loaded: NetFilter module - Loaded: USBMonitor module - Loaded: USB module Configuring services... - Loaded: Web service - Loaded: Zone access service Installing Python bindings... - Installed: Bindings for Python 2.4 - Installed: Bindings for Python 2.5 - Installed: Bindings for Python 2.6 Updating the boot archive... Installation of <SUNWvbox> was successful.
The default directory for the VirtualBox components is /opt/VirtualBox. The user commands VirtualBox, VBoxManage, VBoxSDL, VBoxHeadless, and VBoxQtconfig are all symbolically linked into /usr/bin so that they are available for all users on the system. In general, no special privileges are required to run VirtualBox on Solaris other than appropriate file permissions to devices and disk images. The privilege net_priv_addr would be required to forward a host port number less than 1024 to a guest, but this configuration is strongly discouraged.
When a user runs VirtualBox, all of the machine definitions and private disk images are stored by default in a directory named .VirtualBox in the user's home directory. Although the machine configuration files are small, disk images can grow quite large. To change the locations where these files are stored, click File Preferences in the VirtualBox graphical interface or use the VBoxManage setproperty command. Figure 5.8 shows how to change those preferences to a different location.
Figure 5.8 Changing the Location of Guest Disks and Machine Definitions
VirtualBox disk images and machine configurations can be shared among many users. All that is required to share machine configurations and disk images is read and write file permissions to the associated files.